Switching to Layers tab stops background music

Hi, with the new version of uMake 3.9, when you select the layers tab the background music from the music app stops playing.

The only thing I can think of that might cause this issue, is when you select the layers tab for the first time, a pop up video plays telling you about the new features (which of course stops any background audio playing).

My guess would be for some reason selecting the layers tab after this still stops the audio, but doesn’t play open the pop up video.

Not a major issue, just annoying when your in the zone listening to music while designing and the song stops and you have to keep restarting it (depending on how many times you selecting the layers tab).

Thanks in advance

Thanks for letting us know! We will look into this issue.

Thanks again,
Evi

1 Like

Hi again,

Updated to ver 3.9.1
Music issue is still there (wasn’t expecting it to be fixed in this update as it was released pretty quickly after I discovered the issue). Issue happens on both my iPad Pro 3rd Gen running iOS12.4.1 and also my iPhone 6s running iOS 13.4.1

  • Any designs opened in uMake ver 3.9.0 will crash if you downgrade to uMake ver 3.8.x or below. I haven’t tested if this is still the case for ver 3.9.1

  • Sometimes when deleting a tab the uMake app will lock up, when this happens, I just switch to another app, wait a second and switch back to uMake and it works fine again. It happens less frequently than it did in version 3.9.0 it seems.

  • There is a slight flickering issue when dragging textures to onto surfaces, which makes it hard to place sometimes. It seems the texture is jumping between different surfaces, which makes it hard to ‘let go’ of your finger and see if the texture lands on the right surface.

Aside from all that, still loving the app and keep up the good work :slight_smile:

Hi @Kiwi,

Thanks for the feedback!

  1. We’re still trying to look for solutions to avoid the audio conflict.
  2. I highly recommend not to downgrade uMake to a different version as it might cause issues we can’t predict.
  3. What do you mean by deleting a tab?
  4. We will look into this the surfaces flickering issue you mentioned. Thanks!

Thanks,
Evi

Hi Evi,

Apologies for saying tab, I was thinking of a layer as shown in the picture below:

Sometimes when deleting a layer, the app would freeze, I’ve attached a link to a small video from my iPhone showing the issue. Sometimes it happens right away, and sometimes happens after deleting a third layer.
https://www.dropbox.com/s/1iez1h6rzl77wah/uMake_layer.MOV?dl=0”

Thanks

Kiwi

Quick update:

  1. Will be fixed in the next update
  2. Thanks for the example, we will look into it
  3. Fixed and will be part of our next update

Thanks,
Evi

1 Like

Hi Evi,

Just an update with version 3.9.3 (two updates since the previous issues).

  1. Audio Conflict
  • Not fixed (You said you’re still looking into it so it’s not an issue, I find not using the audio app on the iPad helps free up some memory and I have less crashes when switching between uMake and Affinity Photo. But that could just be me.)
  1. Deleting tabs
  • Swiping and deleting tabs from the right works, but the app still freezes when deleting tabs the the menu (as shown in attached video - you can’t see my finger as I used iPad’s built in screen capture)
  1. Flickering when dropping textures onto objects
  • Fixed (awesome thanks!)

Not in a hurry for the fixes, in fact I hope the devs stay safe from the virus :slight_smile: instead.

Kiwi

Thank you for sending this!

  1. Audio - We fixed the issue and it will be part of our next update.

  2. Deleting layers - can you please send us the UMK file you’re working on to "hello@umake.com" and we will try to reproduce the bug you have.

Thanks!
Evi

1 Like