Cannot extrude an irregular edited shape

Hi there.

I’m new to umake, however I have experience in 3D design.
I’m trying to create a replica of a car badge, which is very irregular. My approach was to create a shape using splines (either by precision or sketching) , I close the shape but the autosurface seems not to be aware of that. I then assumed that the shape wasn’t probably correctly closed. I started over, making sure that every point connects to the next. No way, I’m missing something or the program is not doing what’s expected.
In my third attempt, I draw a sketch in one single trace, as close to the final shape as I could. This time, the surface was completed and it turned to blue in color. Okay, I finished it then by touching the green button. I spent about 20 minutes editing the shape to make it fit to the image I had in a lower layer. Then I tried to extrude the shape into a volume. The only thing I could extrude is the border line, no chance to extrude it into a volume. I’m not sure if that’s is actually possible? Watching the videos I only can see that the extrusion process seems to work only with shapes made of one single trace, but I didn’t find a tutorial where you edit the shape and then make that it into a volume by extrusion. For example, say that you draw the shape of a dog. Then you edit the shape to make it look more like a dog. Then you extrude that shape pretending to give the dog a volume, then you discover that only the shape is extruded , not the surface, leaving kinda a box with the shape of a dog. Am I doing wrong or is it a missing feature? I don’t discard I misunderstood the procedure. Is there a trick to make the edited shape extrudable as a volume?. Thanks.

Hi @alexmake

Thank you for contacting us here!

Would it be possible for you to upload a screenshot of your creation? Maybe even attaching the original .UMK file?

I suspect the surface created is not a planar surface (it means it’s 3D) and therefore, this prevents you from pushing or pulling the surface itself. We’re working on improving this experience, so it would be easier to push/pull 3D surfaces.

Thanks,
Evi

Hi. I’m attaching screenshots of my last try unfinished. One is just the shape, the second is the same shape as I select it and the third is the extrusion. It extrudes only the contour, since it does not interpret it as a planar. If this is a non-closed-shape problem, I can say that it’s not easy (at least for me now) to close a shape and make it a surface. I tried as I said, drawing a shape with one single trace , but as soon as I try modifying it to accommodate the shape, it is not a surface anymore. Correction : the forum only let me upload two images because I’m new to it. So, the first one is the shape in edition stage and the second the extrusion.

I’m trying to get the .umk file for you…

@alexmake I changed the rules so you an upload more images now.

Hi. Sorry about the delay. I’m attaching the model as exported from umake. Hope it helps.
Note: export produces a zip file, containing the base image I’m using and the model. Unfortunately, the forum rules only let me upload image files and .umk. There were a couple of more files inside the zip files (.astc & .png) that I’m not uploading here.
Let me know if this is okay for you.model.umk (3.3 KB)
Thanks!

Hi @alexmake,

I think the issue was with the curve itself - it was too complex as one unified curve, and what I did is simply disconnect one of its control points so that it will behave as two lines connected.

logo.zip (705.3 KB)

You can import the .zip as it is into uMake.

I also improved the tracing by adding more control points so it would be closer to the original photo.

P.S. uploading .zip files in the forum is working now.

Let me know if this helps.

Thanks,
Evi

Hi.
Thanks for your reply. I will try (I had to travel, job calls). I understand what you say. Probably I still have not a very good skill on curves to make it work as due. However, I have a couple of questions about it. At first, the model I’ve sent is just one of the attempts I did. I tried many control points before and I’ve got the shape very close as you did in your corrected shape as I can see on the picture, but because of some unknown reason , at certain point the surface turns back into separate curves. It’s like it disconnects at one of the multiple points and it’s not a close shape any more. I realize of that, because the surface loses the blue color and only the curves remain. I then try to reconnect the points but it’s not easy. Is there a snap for this? I mean, if I move a point away from its “connection” accidentally and then want to reconnect it to the same point, I cannot achieve it; at least not always. Also it becomes difficult for me to discover which point is the one I have disconnected (i.e. where the shape is open).
Another thing I’ve noticed, is that, when you are sketching , say a new shape, it’s difficult to keep on 2D. A subtle movement of my pencil (or a screen touch) turns it immediately in a 3D space. Is there a “lock” to stay in 2D, despite you touch the screen or not? If not, I guess it could perhaps be a new feature. Thanks!

@alexmake

Thanks for the feedback!

  1. For precise tracing over, we recommend using the “Precision” tool, as it would give you more accurate results and you would be more “in control” of the number of control points created per curve.

  2. When you select multiple curves connected to each other and then tap on “Edit”: when you see a green control point, it means that the curves are snapped to each other but they’re not merged. Full blue control points would mean that these control points were merged together. More about this can be found here: https://www.umake.xyz/learn/anatomy-of-curves/

  3. Surfaces - complex curves could create very complex surfaces, this is why you would have to manage the curves created to avoid over-complexity.

  4. Apple Pencil Mode and sketching - we will improve this behavior based on your feedback, so accidental touch won’t orbit the camera.

I hope this answers your questions. Let me know if you have any questions!

Thanks,
Evi

Hi Evi.
Thanks, I think it’s going better now with your advise. I will practice more using curves and let you know.

Regards,
Alex.-

1 Like